Jump to content
Vari-Lite Controls Support Forum

Fat Frog CFT & IFT problems


Recommended Posts

I've got 2 Fat Frogs, running 10.9.1, with badly outdated fixture libraries. I've downloaded the filtered .ift file, but it's still to large for a 1.44 floppy.

I have the tools to create smaller .ift and .cft files, but the floppy system itself is stopping me.


A disk formatted by the desk is FAT12. My PC wont' read FAT12.

If I have the PC format the disk, the Frog won't see or read it.

My Mac will see and read/write the FAT12 format.

When I format using the Frog, create the file on the PC, and load it onto the disk using the Mac (yea, I hear ya), the desk will see the disk but not the file when looking for .cft files, and won't see the disk at all when looking for .ift files.


I'm running out of ways to put this together. Help?

Link to comment
Share on other sites

What do you mean your PC won't read the floppy? We have converted our FF to USB now, but before that I used to prepare floppies [including formatiing] for it using a cheap USB-connected floppy drive from my WIndows 7 PC, which the FF happily read (and wrote to for show files).


The physical floppy disk used must be 3.5” PC compatible formatted to 1.44Mb (HD DS) and not bootable. Pre-formatted diskettes worked fine for me on both the FF and other desks (such as Strand 520, Strand 300, ETC Express).



Link to comment
Share on other sites

I too am using a usb external floppy drive. The PC won't write to a floppy disk (1.44 HD) that came from the desk without reformatting it first. I tried formatting it as FAT, and 16, 32, 64, 512, and default bit, but the Frog came up with "no disk in drive" every time.


Please tell me more about your conversion to USB. It may be my best solution.


Thank You.

Link to comment
Share on other sites

If you format a floppy in the FF, and restart it does it give the same message or does the diskette run for a bit then desk startup as normal (which is what should happen)? I presume that you have been using it to save and load shows? If not:

  • Have you opened up the desk and check that none of the cabling has come adrift?
  • Is the memory behaving between power offs, if not change the battery as this has all kinds of undesirable effects if it goes flat.
  • Have you cleaned the diskette drive recently (you used to be able to get cleaning diskettes but might not be so easy nowadays)?

If the diskette drive in the FF is working normally when the FF formats the disk, this is a mystery although not impossible that one or other drive is misaligned to each other.


As far as converting to USB, see BlueRoom near the bottom of the first page where PaulDF says what he did which basically I copied (and detailed in following page). Beware that what you get are up to 100 x 1.44MB partitions on a USB stick which runs at the speed of a floppy disk. The changeover was very easy and has worked fine since. Also be careful there are MANY models of this drive which LOOK exactly the same on offer, only one [or a few] of which will work on the FF.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.