Jump to content
Zero 88 Community Support Forum

can be delate


Recommended Posts

Hi Pip,

ZerOS isn't compatible with FROG2. The latest software release for FROG2 is ZerOS available here...


Download the .zip file, extract it, run the .exe file on your PC with a blank USB stick plugged in and follow the on screen instructions. Then plug the memory stick into the console and boot the FROG2. You should then see a screen that says Install ZerOS

Hope that helps, any queries let me know.


Link to comment
Share on other sites

  • 2 months later...

I must say I am weary of trying to update software on Zero 88 desks. This goes back to Sirius with the special cards! Then it was floppy disks that could not be recognized. Over time this was remedied by putting a usb emulator drive in. Finally its the Frog 2 which I have only once updated the software and that was by resorting to the cd drive version. This time I decided to try the USB route and once again it failed. I no longer have the original stick but have followed all the suggestions with a stick used to back up shows. Still no luck. Are the official sticks still around to buy?

Link to comment
Share on other sites

Hi Nick,

In our later software versions (unfortunately unavailable on FROG2) you can load software updates in, in a similar way to loading a show file. 

Have you tried this on a Windows 7 PC...


We have come across a few people having issues with Windows 10 PCs. As long as your USB stick has a MBR, it would be detected by the FROG2 during startup. Therefore try low capacity USB sticks, and ensure they are FAT format. If you continue to have issues, try formatting a CD with a formatted software image on. 

Hope that helps, any queries let me know. 


Link to comment
Share on other sites

Hi Edward

Due to unforeseen circumstances I no longer have a windows 7 system! However having seen the prompt that there was an iso file for a disk, there wasn't the last time I updates a few years ago, I have bought a disk and successfully done the update.

The first issue is when I press setup to import a file it no longer opens the familiar page to load files etc. Its probably obvious. I have just come on line to have search!


Thanks for the reply though



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.